error al crear nuevo proyecto con Angular-cli

Cuando bash crear un nuevo proyecto con el comando, ng nuevo nombre de proyecto , aparece un error como el siguiente:

fs.js: 640 return binding.open (pathModule._makeLong (path), stringToFlags (flags), mode); ^

TypeError: la ruta debe ser una cadena o búfer en TypeError (nativo) en Object.fs.openSync (fs.js: 640: 18) en Object.fs.readFileSync (fs.js: 508: 33) en Function.Version.fromProject (/usr/lib/node_modules/angular-cli/upgrade/version.js:87:31) en Function.Version.isPreWebpack (/usr/lib/node_modules/angular-cli/upgrade/version.js:111:31) en Function.Version.assertPostWebpackVersion (/usr/lib/node_modules/angular-cli/upgrade/version.js:97:18) en / usr / lib / node_modules / angle-cli / bin / ng: 25: 15 at / usr /lib/node_modules/angular-cli/node_modules/resolve/lib/async.js:44:21 en ondir (/usr/lib/node_modules/angular-cli/node_modules/resolve/lib/async.js:187:31) en /usr/lib/node_modules/angular-cli/node_modules/resolve/lib/async.js:153:39

Sospecho algunos problemas al instalar angular-cli pero no estoy seguro. Cualquier ayuda sería útil.

Tenía el mismo problema fue capaz de solucionarlo haciendo lo siguiente:

  npm uninstall -g angular-cli npm cache clean npm install -g node-gyp npm install -g angular-cli 

Luego haga ng –version para ver si se instaló correctamente.

Estaba teniendo el mismo problema y esta publicación fue útil: https://github.com/angular/angular-cli/issues/2135

Tal vez sea un poco demasiado intrincado para recomendarlo como una solución, pero esta respuesta al menos me hizo seguir:

La solución más sencilla para continuar trabajando en su proyecto es la línea de comentarios 25 de node_modules / angular-cli / bin / ng: // Version.assertPostWebpackVersion (); Hasta que se arregle adecuadamente.

Por favor, intente npm install -g webpack antes de npm install -g angular-cli